Rival Platform Outage | Reporting | EU Region Only

Incident Report for Rival Technologies

Resolved

We identified a discrepancy related to the upgrade and have remediated the issue. Reporting in EU region is expected to be fully resolved and operating normally. We will continue to monitor to ensure stability.
Posted Jan 27, 2026 - 17:40 PST

Investigating

Issue: We are currently experiencing issues with our reports (Insight and Custom reports) in EU region of our platform. Some datapoints may not be displaying properly in the custom/insight reports filtering list and there is an issue with displaying some of the widgets.

Impact: Any new custom/insight report created will have issues with filtering and displaying widgets. Users should be able to view existing reports.

Regions Affected: EU region only

Workaround: None

Status: Rival team is actively investigating. We'll provide another update as soon as more information becomes available.
Posted Jan 27, 2026 - 00:33 PST
This incident affected: Reporting.